Common Vulnerabilities and Exposures

From SpinetiX Support Wiki

Jump to: navigation, search

This page is related to security of the HMP system.

Description

CVE stands for Common Vulnerabilities and Exposures, which is a dictionary of publicly known information security vulnerabilities and exposures.

  • An information security "vulnerability" is a mistake in software that can be directly used by a hacker to gain access to a system or network.
  • An information security "exposure" is a system configuration issue or a mistake in software that allows access to information or capabilities that can be used by a hacker as a stepping-stone into a system or network.

List of CVEs

The table below contains a list of CVEs related to the HMP devices, grouped by the affected component and the firmware version in which they were fixed (for more details, see firmware release notes).

CVE codes Component Fixed in firmware Notes
CVE-2015-0228 Apache httpd Low security impact: mod_lua: Crash in websockets PING handling. Not vulnerable as it only affects httpd 2.4.7 and later.
CVE-2016-2108 OpenSSL 4.0.2 build 2, 3.2.2 Could affect the device.
CVE-2016-0798, CVE-2016-2176, CVE-2016-2107 OpenSSL 4.0.2 build 2, 3.2.2 Do not affect the device (no firmware component enables TLS-SRP).
CVE-2016-2105, CVE-2016-2106, CVE-2016-2109 OpenSSL 4.0.2 build 2, 3.2.2 Should not affect the device.
CVE-2015-8388, CVE-2015-8390, CVE-2015-8381, CVE-2015-8395, CVE-2015-8393, CVE-2015-8389, CVE-2015-8391, CVE-2015-8394, CVE-2015-8385, CVE-2015-8392, CVE-2015-8386, CVE-2015-8380, CVE-2015-8387, CVE-2015-8384 pcre 4.0.2 Could affect the device.
CVE-2015-7499, CVE-2015-7500, CVE-2015-7498, CVE-2015-8241, CVE-2015-8317 libxml2 4.0.2 Could affect the device.
CVE-2016-1907 OpenSSH 4.0.2 Could affect the device.
CVE-2016-0777, CVE-2016-0778 OpenSSH 4.0.2 Do not affect the device.
CVE-2015-7575 OpenSSL 4.0.2 Could affect the device. Does not affect 3.x firmware versions because OpenSSL 0.9.8 and lower are not affected.
CVE-2015-3197 OpenSSL 4.0.2, 3.2.2 Could affect the device.
CVE-2015-6831, CVE-2016-1903, CVE-2015-6832, CVE-2015-6836, CVE-2015-6833, CVE-2015-5590 PHP 4.0.2 Could affect the device.
CVE-2015-8472 libpng 4.0.2, 3.2.2 Could affect the device.
CVE-2015-8605 dhcp 4.0.2 Could affect the device.
CVE-2015-7547 glibc 4.0.1 build 2 Firmware 3.x or lower is not affected by the glibc getaddrinfo() stack-based buffer overflow vulnerability.
CVE-2016-0800, CVE-2016-0705, CVE-2016-0797, CVE-2016-0799, CVE-2016-0702 OpenSSL 4.0.1 build 2, 3.2.2 Could affect the device. SSLv2 has been removed as part of the fix for CVE-2016-0800.
CVE-2016-0703, CVE-2016-0704 OpenSSL 4.0.1, 3.2.1 Solved as a side effect of the fix for CVE-2015-0293.
CVE-2015-7853, CVE-2015-7852, CVE-2015-7855, CVE-2015-7704, CVE-2015-7705 NTP 4.0.1 Could affect the device.
CVE-2015-7852, CVE-2015-7850, CVE-2015-7701, CVE-2015-7871, CVE-2015-7703, CVE-2015-7691, CVE-2015-7692 NTP 4.0.1 Should not affect the device.
CVE-2015-6564, CVE-2015-6563 OpenSSH 4.0.1 Did not affect the device in normal operating conditions.
CVE-2015-3194, CVE-2015-3196 OpenSSH 4.0.1 Could affect the device.
CVE-2015-3195 OpenSSH 4.0.1 Should not affect the device.
CVE-2015-8382, CVE-2015-2328, CVE-2015-2327 pcre 4.0.1 Could potentially affect the device.
CVE-2015-1283 expat 4.0.1 Could affect the device.
CVE-2015-5312, CVE-2015-7497, CVE-2015-8242, CVE-2015-8035, CVE-2015-7942, CVE-2015-7941 libxml2 4.0.1 Could affect the device.
CVE-2015-8126 libpng 4.0.1, 3.2.2 Could affect the device.
CVE-2014-9745 FreeType 4.0.1 Could affect the device.
CVE-2015-7803, CVE-2015-7804 PHP 4.0.1 Should not affect the device.
CVE-2013-5704 Apache httpd 4.0.1, 3.2.2 Low security impact: HTTP Trailers processing bypass.
CVE-2013-6438 Apache httpd 4.0.0 Moderate security impact: mod_dav crash.
CVE-2014-0098, CVE-2014-0098 Apache httpd 4.0.0 Low security impact: mod_log_config crash.
CVE-2013-4352, CVE-2014-3581 Apache httpd 4.0.0 Low security impact: mod_cache crash.
CVE-2014-0226 Apache httpd 4.0.0, 3.2.2 Moderate security impact: mod_status buffer overflow. Does not affect lower firmware versions because threaded MPM is not used.
CVE-2014-0118 Apache httpd 4.0.0, 3.2.2 Moderate security impact: mod_deflate denial of service. Does not affect lower firmware versions because mod_deflate is not used.
CVE-2014-0117 Apache httpd 4.0.0 Moderate security impact: mod_proxy denial of service.
CVE-2014-0231 Apache httpd 4.0.0, 3.2.2 Important security impact: mod_cgid denial of service. Does not affect lower firmware versions because mod_cgid is not used.
CVE-2014-3583 Apache httpd 4.0.0 Low security impact: mod_proxy_fcgi out-of-bounds memory read.
CVE-2014-8109 Apache httpd 4.0.0 Low security impact: mod_lua multiple "Require" directive handling is broken.
CVE-2015-3185 Apache httpd 4.0.0 Low security impact: ap_some_auth_required API unusable.
CVE-2015-3183 Apache httpd 4.0.0, 3.2.2 Low security impact: HTTP request smuggling attack against chunked request parser.
CVE-2015-0253 Apache httpd 4.0.0 Low security impact: Crash in ErrorDocument 400 handling.
CVE-2015-8540, CVE-2015-7981, CVE-2014-9495, CVE-2012-3386, CVE-2011-3048, CVE-2011-3026, CVE-2011-2690, CVE-2011-2691, CVE-2011-2692, CVE-2010-1205, CVE-2012-3425 libpng 3.2.2 Updated libpng to 1.2.56.
CVE-2015-1788, CVE-2015-1789, CVE-2015-1791, CVE-2015-0286, CVE-2015-0287, CVE-2015-0293, CVE-2015-0209, CVE-2015-0288, CVE-2014-3570, CVE-2014-3571, CVE-2015-0204, CVE-2014-3572, CVE-2014-8275, CVE-2014-3569, CVE-2014-3567, CVE-2014-3568 OpenSSL 3.2.1 Could affect the device.
CVE-2015-3195, CVE-2015-1790, CVE-2015-1792, CVE-2015-0289 OpenSSL 3.2.1 Should not affect the device.
CVE-2015-0235 glibc 3.1.1 build 2, 3.0.6 build 3, 2.2.7 build 3 The glibc GHOST vulnerability could potentially lead to execution of arbitrary commands, although no vector of attack is currently known in the case of HMP.
CVE-2013-6438, CVE-2013-1896 Apache httpd 3.1.0 Updated HTTP server to Apache httpd 2.2.27, fixing security vulnerabilities which could affect the HMP.
CVE-2014-6271, CVE-2014-6277, CVE-2014-6278, CVE-2014-7169, CVE-2014-7186, CVE-2014-7187 bash 3.1.0,

3.0.6 build 2, 2.2.7 build 2

Fixed the Shellshock bash vulnerabilities which could potentially lead to execution of arbitrary commands, although no vector of attack is currently known.
CVE-2005-2974, CVE-2005-3350 giflib 3.0.0 Updated giflib to 5.0.0.
CVE-2012-0037 raptor 3.0.0 Updated raptor to 2.0.8.
CVE-2012-1126 to CVE-2012-1144, CVE-2011-3439, CVE-2011-3256, CVE-2011-0226 FreeType 3.0.0 Updated FreeType to 2.4.10.
CVE-2012-0841, CVE-2011-3905, CVE-2010-4008, CVE-2011-2834, CVE-2011-1944, CVE-2011-0216, CVE-2011-3919 libxml2 3.0.0 Updated libxml2 to 2.9.0.
CVE-2008-4316 glib 3.0.0 Updated glib to 2.34.1.
CVE-2012-5134 libxml2 3.0.0, 2.2.6 Fixed.
CVE-2011-3368 Apache httpd 2.2.5 Updated the embedded HTTP server to Apache 2.2.22.
CVE-2011-1002 avahi 2.2.5 Fixed vulnerability (denial of service when empty UDP packets are received) of the Bonjour daemon (avahi).
CVE-2012-1147, CVE-2012-1148 expat 2.2.5 Updated expat library.
CVE-2011-3192 Apache httpd 2.2.4 Updated the embedded HTTP server to Apache 2.2.21.
CVE-2010-1452, CVE-2009-2412, CVE-2009-0023, CVE-2009-1955, CVE-2009-1956 Apache httpd 2.2.3 Updated the embedded HTTP server to Apache 2.2.19.
CVE-2010-0830, CVE-2009-4880, CVE-2009-4881, CVE-2010-0296 libc 2.2.1 Fixed.
CVE-2009-3560, CVE-2009-3720 libexpat 2.1.2 Fixed.
CVE-2009-3563 NTP 2.1.1 Fixed.
CVE-2009-3555 OpenSSL 2.1.1 Fixed.


Commonly-flagged vulnerabilities which do not apply to the HMP:

  • CVE-2008-2939 affects a module we do not use (mod_proxy_ftp).
  • CVE-2009-1191 affects a module we do not implement (mod_proxy_ajp.c).
  • CVE-2009-1195 concerns .htaccess which is not used.
  • CVE-2009-1890 affects a module we do not implement (mod_proxy).
  • CVE-2009-1891 affects a module we do not implement (mod_deflate).
  • CVE-2009-2699 only affects Solaris 10 and OpenSolaris.
  • CVE-2009-3095 and CVE-2009-3094 affect a module we do not use (mod_proxy_ftp).
  • CVE-2010-0408 only affects Apache on Windows, Netware, and OS/2.
  • CVE-2010-0425 only affects Apache on Windows.
  • CVE-2010-0434 only affects multi-threaded MPM systems - the HMP is not part of this category.
  • CVE-2011-3348 affects a module we do not implement (mod_proxy_ajp).
  • CVE-2011-3368 no proxying enabled.
  • CVE-2011-3607 use of .htaccess files is disabled.
  • CVE-2012-0021 cookie logging is not used.
  • CVE-2012-0031 no unprivileged children are run.
  • CVE-2012-0883 LD_LIBRARY_PATH is not used.
  • CVE-2012-2687 multiviews is not enabled.
  • CVE-2012-3499 only affects modules not included or whose features are not enabled.
  • CVE-2012-4557 affects a module we do not implement (mod_proxy_ajp).
  • CVE-2012-4558 only affects modules not included.
  • CVE-2014-3523 (Apache httpd - WinNT MPM denial of service) does not affect the HMP since this is a Windows specific vulnerability.
This page was last modified on 30 May 2016, at 18:55.